Detector behavior in high dose rate levels


Advanced search

Message boards : Science : Detector behavior in high dose rate levels

Author Message
Profile jhelebrant
Avatar
Send message
Joined: 30 Jul 12
Posts: 27
Credit: 1,521
RAC: 0
Message 1704 - Posted: 22 Apr 2013 | 9:19:26 UTC

Hi,
we did some testing of the detector using 226Ra source (so called radium needle) with activity approx. 3.5 MBq. However the detector seems to show much smaller values:


link to better quality image

Are there any display limit for measurements or is the problem of electronics? As I know, the GM tube can measure up to miliSieverts per hour.

thanks

PS: going to continue in testing[/img]

Profile TJM
Project administrator
Project developer
Project tester
Send message
Joined: 16 Apr 11
Posts: 291
Credit: 1,081,449
RAC: 472

Message 1710 - Posted: 26 Apr 2013 | 7:04:50 UTC - in response to Message 1704.
Last modified: 26 Apr 2013 | 7:29:54 UTC

I'm not sure about v3 sensor limits (on photo), I'll check it's hardware/software today with a signal generator.

Older desings are able to measure values far beyond the tube limits, which AFAIR can't go higher than 5k pulses/s.
Of course it does not mean they are super accurate, I have tested them with weak radioactive sources and during each test I had some differences in readings compared to older russian dosimeter. I think part of the error comes from cpm -> µSv conversion.

Profile TJM
Project administrator
Project developer
Project tester
Send message
Joined: 16 Apr 11
Posts: 291
Credit: 1,081,449
RAC: 472

Message 1711 - Posted: 26 Apr 2013 | 8:27:11 UTC - in response to Message 1710.
Last modified: 26 Apr 2013 | 10:48:09 UTC

So I did some tests.
The detector reads up to 999µSv/h without problem. I haven't checked the accuracy of readings yet, just verified that it's able to count at fairly high frequency.
For the test I used bad SBM-20 which generates high frequency random pulses resulting in readings around ~0.9-1,1mSv.

However, over 1mSv/h the sensor does not display any value at all. Perhaps it's because I have v3 from the test/beta batch, I'll ask RK if he did any changes since then.

Even though the display is gone, the detector works and the software reads correct values. Right now I've switched the sensor to a known good (old v1.5 which was stress tested a lot) to compare readings with the same tube.





EDIT: Could you repeat the test with the most sensitive part closer to the source ? The tube is on the other side:

Profile jhelebrant
Avatar
Send message
Joined: 30 Jul 12
Posts: 27
Credit: 1,521
RAC: 0
Message 1717 - Posted: 2 May 2013 | 8:34:39 UTC

Thanks for suggestion. I moved the source to the other side and the results are much better.



Okay, there are some differences in results, but according to my colleague even a small difference in distance has a big influence in this case.

However, very positive and important result for us is that the detector does not have problems with measuring such high dose rates.



We already tested some other sensors (but with the same GM tube) and they had problems.

exsafs
Avatar
Send message
Joined: 25 Jun 11
Posts: 14
Credit: 5,359
RAC: 0
Message 1721 - Posted: 15 May 2013 | 23:19:12 UTC

u will indeed need a source of large activity in order to get a homogeneous radiation field at a certain distance. only this will ensure a reliable and meaningful comparison between dose rate meters.

exsafs
Avatar
Send message
Joined: 25 Jun 11
Posts: 14
Credit: 5,359
RAC: 0
Message 3047 - Posted: 5 Feb 2015 | 19:25:36 UTC

I have something to add here.
Just dug out my old R@H v1.5 detector recently and tested that one with a 3 GBq Be-7 source in our lab.
The actual dose rate at 1 cm distance should be around 15 mSv/h, but the detector was not capable of measuring anything above 1 mSv/h.

Post to thread

Message boards : Science : Detector behavior in high dose rate levels


Main page · Your account · Message boards


Copyright © 2019 BOINC@Poland | Open Science for the future