Third Batch Kit V2.61 has problems with the usb communication


Advanced search

Message boards : Science : Third Batch Kit V2.61 has problems with the usb communication

Author Message
hottec
Send message
Joined: 21 Mar 15
Posts: 3
Credit: 614
RAC: 0
Message 3194 - Posted: 31 Mar 2015 | 0:31:20 UTC

Hallo,
i received the third batch Kit V2.61. I build the kit complete and the unit works fine with display. But there is a big problem with the usb communication. I check the unit or pcb complete with an oszilloscop. Technical with the hardware is all ok. So i began to check the communication for the usb port.

The boinc diagram in the map shows also the communication error because there are disconnects. So i check it with the rad.py

And the result is that here also after 30-100counts the communication over usb port lost and only a usb disconnect from pc and reconnect brings the communication back with the device. This bug i can reproduce since the last days. in the rad.py script is an reconnect function, but the unit ignore that complete.

So who can verify that or can tell me a solution. i think it is a software bug
in the avr firmware V2.61!

hottec
Send message
Joined: 21 Mar 15
Posts: 3
Credit: 614
RAC: 0
Message 3195 - Posted: 31 Mar 2015 | 0:53:28 UTC

I also found out that usbport v1.1 protokoll the unit works longer with the rad.py script.
with usb v2.0 the script works only max. 10 counts

The energy control for usb is also on my windows pc switched off .

HA-SOFT, s.r.o.
Send message
Joined: 6 Mar 14
Posts: 6
Credit: 191,838
RAC: 104

Message 3196 - Posted: 31 Mar 2015 | 7:55:15 UTC - in response to Message 3195.

The problem is in usb implementation on detector side which is not good. Detector can not recover from this state itself. I think it's EMI on usb cable which make detector stop communicating.

Try to place wire choke on usb cable as close as possible to detector. It may help.

hottec
Send message
Joined: 21 Mar 15
Posts: 3
Credit: 614
RAC: 0
Message 3197 - Posted: 31 Mar 2015 | 10:19:05 UTC

thank you for your answer.
your are possible right with the EMI idea. I also thought at that.

i checked it with a wire choke on usb cable as close as possible to detector,
but nothing change. :-(

here is a screenshot log of rad.py script at a usb port V2.0, the communication
lost after 4 counts:


Manufacturer: radioactiveathome.org
Product: Radiation Detector KIT
Status: [0, 153, 19, 0, 0, 3, 0, 0]
Realtime clock: 5.017s
Counts: 3
counting - please wait...

Realtime clock: 8.162s, Counts: 4
29.4046 CPM, 0.171756 uSv/h
Corrected 29.4074 CPM, 0.171772+-0.0858778 uSv/h
Realtime clock: 11.292s, Counts: 4
21.254 CPM, 0.124147 uSv/h
Corrected 21.2555 CPM, 0.124156+-0.0620736 uSv/h
Something wrong with getting info from the device!!
Closing device
Time sleeping for 5 Seconds
Trying now to reopen selected device
open failed
You probably don't have the hard coded hid. Update the hid.device line
in this script with one from the enumeration list output above and try again.
Have a nice day!




--Norbert
Send message
Joined: 6 Jan 15
Posts: 69
Credit: 0
RAC: 0
Message 3217 - Posted: 9 Apr 2015 | 2:04:11 UTC

Hottec, if you can't locate the USB problem, I found a workaround. My USB problem is different (will not enumerate at all), but the RS232 TTL serial data from CON1 is fine. See my posts in the "..now what?" thread in this board. There is another world map that can read the serial data from this detector, and it also shows all the Radiation@home detectors as well.

There is a plan for reciprocal sharing of data between the 2 sites, and I hope to see RadMon.org data on this map someday.

Post to thread

Message boards : Science : Third Batch Kit V2.61 has problems with the usb communication


Main page · Your account · Message boards


Copyright © 2019 BOINC@Poland | Open Science for the future