Posts by Dagorath

1) Message boards : Number crunching : Running the sensor on linux (Message 1637)
Posted 4137 days ago by Dagorath
Hello all.
I'm running Ubuntu 12.04.
Confronted with the problem of non-recognition sensor (progress bar to zero % all the time), a friend of the Alliance Francophone gave me the solution on our forum => http://forum.boinc-af.org / index.php? topic = 4163.msg313231; topicseen # msg313231
Using the script rad_sensor_ubu.sh, edit the file /etc/udev/rules.d/53.radioactive.rules and must be replaced SYSFS by ATTRS.
For explanation, SYSFS is no longer supported since version 174 udev daemon. You have to use ATTRS instead.
And everything works normally.

Thank you.
Bye


There is some misinformation in the above, I think just a typo probably or perhaps that curious French desire to put an S at the end of words but never pronounce it. Actually you must use ATTR not ATTRS.

Also the OP suggested naming the file 53-radioactive.rules. The quote above suggests 53.radioactive.rules. Note the former uses a - in the name, the latter replaces the dash with a dot. The name seems to be important so I will attempt to explain what I have discovered about it in the hopes of sparing others the grief I just went through. Read carefully because I don't explain this very well.

The 53-radioactive.rules name worked for me on Ubuntu 11.10 but since upgrading to Ubuntu 12.10 it appears the detector will not be recognized on my system if I use that filename. According to /etc/udev/rules.d/README (found on Ubuntu 12.10 but perhaps not other distros/versions) the number in the prefix determines the order in which the various device rules files are applied. Mind that works only if the number is followed by a dash character. If you use a period after the number instead of a dash, as is suggested in the above quote, then the number is ignored and the rules file will be applied last after all other rules files have been applied.

The reason I mention that is because not only did I have to switch to using ATTR instead of ATTRS, I also had to replace the dash (-) with a period (.) to get the bloody thing to work on Ubuntu 12.10. In other words it seems the radioactive.rules must be applied last on Ubuntu 12.10. I dunno for sure, just saying what I found does not work versus what does work, for me, YMMV, might not apply to other distros or versions of Ubuntu.

@Dingo... I think the above likely is not related to your troubles.
2) Message boards : Number crunching : Dead sensor ? (Message 1633)
Posted 4140 days ago by Dagorath
Then it is assuredly receiving the +5V it needs.

It's not a terribly complicated circuit, you could probably diagnose and repair it your self if you had a soldering iron and volt meter.

Did you try the cleaning I recommended?

If nothing else works they will likely ask you to return the detector to them for a repair. If not please do not throw the device in the trash. Instead I'll pay the shipping cost to ship it to me in Canada. I can fix it.
3) Message boards : Number crunching : Dead sensor ? (Message 1630)
Posted 4142 days ago by Dagorath
I was thinking that the display should illuminate even if the microprocessor itself is dead or the programming is not working and that if it does not illuminate then it means it's not getting the +5 from the USB port. I could be wrong about the display or it could be the +5 is blocked after it arrives at the detector. A voltmeter would help to determine that.

If everything else fails please do not trash the detector. You could try cleaning the solder side of the PCB with iso-propyl alcohol (rubbing alcohol) and a stiff plastic bristled brush or a brass bristled brush, not a steel brush. They didn't clean the PCBs properly after they soldered the components and I know of 2 detectors that did not work until after they were cleaned properly. Mind yours did work for a while so it is likely not the fault of debris left on the board but I suppose it is possible debris has shifted over time and is now shorting something on the board. Possible but not likely, try the cleaning if they cannot find any other solution.

One more idea to think about... I assume from the credits you have accumulated that you have one of the early detectors that did not come in a box. Did you put it in an enclosure? If not then it is possible some conductive debris has fallen onto the detector and is shorting something. Also, if not properly enclosed it is more subject to static discharge. So is it in a box or is it exposed?
4) Message boards : Number crunching : Dead sensor ? (Message 1627)
Posted 4142 days ago by Dagorath
It is possible the USB port on the computer is dead. Did you try a different device on the port to verify that it still works?

If you have a voltmeter you could check to see if there is +5 volts at the microprocessor.
5) Message boards : Science : Newbie Qs (Message 1618)
Posted 4147 days ago by Dagorath
Sorry if this is a stupid question but... what is a C6979 counter kit and where does one get one (link please)? There might be a way to use it.
6) Message boards : Number crunching : latest detector series not recognized by app on linux (Message 1578)
Posted 4172 days ago by Dagorath
During the weekend I'll patch & update the Raspberry Pi app (until then 3.01 on Pi is not supported).


Just in case you didn't hear about it, the latest BOINC client beta/alpha has changes to ARM architecture recognition. It won't be long before that becomes the released code. You might want to think about that and prepare. I heard about it in this post and this post at Asteroids@home project. I'm not sure if it has implications for R@H, it's just an FYI.
7) Message boards : Science : Detector's schematics&firmware (Message 1577)
Posted 4172 days ago by Dagorath
Thanks for that info, TJM, it clears a lot of confusion and wondering.

I know you guys operate with limited manpower so I can't expect immediate gratification but I would like to take a crack at building 6 or so v3 detectors. The item of lowest priority is the firmware... don't need that for a while. BOM and schematic would be nice though, to get the ball rolling.

8) Message boards : Science : Detector's schematics&firmware (Message 1573)
Posted 4172 days ago by Dagorath
The second post in this thread suggests the latest hardware design is available from http://radioactiveathome.org/en/, just click "Detector". More recent posts from project admins suggest revisions have been made since then. I would appreciate a definite yes or no answer to the question of whether the above link provides the latest revisions or not. If not, is it possible to obtain the latest hardware design and software, please?

I don't necessarily need a current schematic. If revisions consist of just changes to component values and no changes to the network then a simple list of value changes or a current BOM (Bill of Materials) will suffice. A list of pin-pin connect changes would suffice too.

Thanks.
9) Message boards : Science : Detector bugs (Message 1545)
Posted 4191 days ago by Dagorath
USB is a complicated specification and I am far from being an expert on it so I could be wrong but since nobody else seems willing to take a crack at the answer I'll give it a try on the condition that if you quote me I'll deny everything ;-)

USB is able to supply only small amounts of current, 500mA IIRC. If the sum of the currents required by all of the USB devices on any leg (say node) exceeds the limit then I believe that leg protects itself by shutting down. I think each device on any given leg must declare how much current it needs and if the sum of the declarations exceeds the limit then the last device is assumed to be the offender and is denied access, or something like that.

That concern is part of the USB limitation (it's intended primarily for comms not power supply) so it will be a concern for any detector that uses USB. I don't know why it was a potential issue for this project's device. Please refresh my memory if I seem to have forgotten or appear to be unaware of previous discussions/concerns.
10) Message boards : Cafe : Why some detectors are not connected? (Message 1543)
Posted 4192 days ago by Dagorath
Read the instructions <======= a very novel idea

Saenger never throws away an opportunity to correct me therefore I conclude he agrees with me: guilty on two counts of bad action with a URL.

Anyway I decided to attach my host in spite of my earlier "refusal" and guess what I discovered... more bad action. I attached a Linux machine, it downloaded the usual files and the app plus a task. When the task started it crashed. Here are the Event Log entries:

22-Dec-2012 15:13:53 [---] Fetching configuration file from http://radioactiveathome.org/boinc/get_project_config.php
22-Dec-2012 15:14:43 [Radioactive@Home] Master file download succeeded
22-Dec-2012 15:14:48 [Radioactive@Home] Sending scheduler request: Project initialization.
22-Dec-2012 15:14:48 [Radioactive@Home] Requesting new tasks for CPU
22-Dec-2012 15:14:49 [Radioactive@Home] Scheduler request completed: got 1 new tasks
*** stack smashing detected ***: ./boinc terminated
SIGSEGV: segmentation violation
Segmentation fault


I detached that host and attached a different host, another Linux machine, and received the same error. Why do you smash my stack? It's a nice stack so please don't smash it.

Then I attached a Windows machine and that was successful. I assume Windows doesn't have a stack else you would have smashed its stack too! (just kidding)

The Linux app worked fine here for many months. The only thing that changed here was a switch from Ubuntu to Debian. I doubt that's causing the problem. I think the app is attempting to stuff a 20 byte string into an 18 byte char* or something similar.

Bottom line: too much bad action going on here and that's why so few detectors are reporting.


Next 10 posts

Main page · Your account · Message boards


Copyright © 2024 BOINC@Poland | Open Science for the future