Posts by appu

1) Message boards : News : Detector V2.60 (KIT) Firmware Upgrade! (Message 3441)
Posted 1403 days ago by appu
I didn't found the schematic yet but if i remember correctly you can power it via the 6pin Header

Found the Schmetaic here.

The only thing i had to do was to make a connection bewtween the 6pin header of the GigerCounter and my 10pin header of my ISP. I also used the ISP to powering the Counter during flashing.
2) Message boards : Cafe : Pending since 8th march??? (Message 3440)
Posted 1403 days ago by appu
Yeah, some guys (me too) in the "Number crunching" forum noticed this also
3) Message boards : Number crunching : Validator not running since 8th of March !!!! (Message 3433)
Posted 1405 days ago by appu
+1
please do so :)
4) Message boards : News : Detector V2.60 (KIT) Firmware Upgrade! (Message 3432)
Posted 1405 days ago by appu
Well, I just bricked my detector, I can not sit still :)

Everything looked good when i clicked upload FW, the led blinking one time, progress bar, but Radioactive@home never came back in the display.
Any advice? What I need to flash the firmware in other way?

I looked at avrdude installed on my debian pc. Can I use it with the usb to ttl adapter or do I need anything else?

Thanks


You will need and ISP (In-System-Programmer) to run avrdude.
Take a look on the "-c" switch of avrdude. It will show you all compatible AVR-ISPs.
I have a STK500v2 compatible bought on ebay for about 20€

An USBTiny adapter costs about 12€
5) Message boards : News : Detector V2.60 (KIT) Firmware Upgrade! (Message 3410)
Posted 1481 days ago by appu
Hey guys,

i've got three V2.6 Kit (last year i think) with Firmware 1.0

I've tried to update the 1 Detector with Version 1.1

It looks good so far - µC Info worked and i tried to flash the V1.1 release. Also done. But then nothing happens.
Connecting Putty to the RS232 Terminal it shows only the '?' on and on and on.
Looks like the µC hangs continuously in boot mode.
The Flash File is about 17 kB is that right ? (The Flash tool reports only 6190 Bytes)

Is there anyway to get / flash the V1.0 Release


Kind regards
andreas


I've found an AVR-ISP in my drawer and flashed the .hex file via avrdude. Now its working again.

best wishes
andreas
6) Message boards : News : Detector V2.60 (KIT) Firmware Upgrade! (Message 3409)
Posted 1481 days ago by appu
Hey guys,

i've got three V2.6 Kit (last year i think) with Firmware 1.0

I've tried to update the 1 Detector with Version 1.1

It looks good so far - µC Info worked and i tried to flash the V1.1 release. Also done. But then nothing happens.
Connecting Putty to the RS232 Terminal it shows only the '?' on and on and on.
Looks like the µC hangs continuously in boot mode.
The Flash File is about 17 kB is that right ? (The Flash tool reports only 6190 Bytes)

Is there anyway to get / flash the V1.0 Release


Kind regards
andreas
7) Message boards : Cafe : KIT - Discussion [topic OPEN] (Message 2825)
Posted 2017 days ago by appu
Provocator
Hi, I have negative polarity on output from transformer (-200 V). So diode D2 is closed and on C13, C10 is no voltage. I Suppose that transformer's winding is reversed. Unfortunately I see no chance to repair it. Any idea?


If you have a -200V and the winding of the transformer are reversed then you solder the transformer from the bottom of the PCB ;-)


Kidding aside...
but i would say you have placed D2 in the wrong direction. Its a simply Diode Bridge which will let only the postive Voltage thru the Diode (if its placed right). Check the direction of the Diode D2. The Kathode Mark on the Diode should be point / soldered to C13 - Anode to the transformer
8) Message boards : Cafe : KIT - Discussion [topic OPEN] (Message 2817)
Posted 2021 days ago by appu

C11: I don't know what exactly means monolithic. I placed there a ceramic disk. May be fine?

Like "C1, C4, C5, C6, C7, C14, C16" those are also monolithic. Should be a default Ceramic Cap (MLCC).
A short sentence from the EN Wikipedia "It was an American company in the midst of the Apollo program, launched in 1961, pioneered the stacking of multiple discs to create a monolithic block. This “multi-layer ceramic capacitor” (MLCC) was compact and offered high-capacitance capacitors"


R2,R4: I have not put them because I have the expander. Are them absolutely needless?

You mean R3 & R4 ? These are pull-ups for SCL & SDA and should be already placed on your I2C Expander. Also don't mount VR1 & T2
9) Message boards : Cafe : KIT - Discussion [topic OPEN] (Message 2815)
Posted 2021 days ago by appu
It should start without Display, startup delay is about 3sec.

My first thought was also that the system doesn't work, because the Display shows only the black-Char Bars - native I2C Display from Winstar.
I measured the 20 Mhz Freq - OK
also took a look on the TxD from the ATMega - there was traffic.

After some time i found the mistake.
My Display had on Pin 15 (Vee on the Schematic) a negative Vcc Output. This pin is connected with the 10k Poti for the contrast. So the contrast dind't go over 0 Volt and was always black.
I disabled / removed the negative Vee Output from the Display and make a bridge with 10 Ohm in serie to Vcc.
After setting the contrast the display works fine, also the backlight.
10) Message boards : News : Second batch of KIT [Detector V2.60] - 100% SOLD! (Message 2801)
Posted 2032 days ago by appu
Package arrived today :)

Thank you Szopler.

greetz
appu / Andreas


Next 10 posts

Main page · Your account · Message boards


Copyright © 2020 BOINC@Poland | Open Science for the future